Xcode8 安装第三方类库管理工具 CocoaPods

CocoaPods是什么?
当开发iOS应用时,会经常使用到很多第三方开源类库,比如JSONKit,AFNetWorking等等。可能某个类库又用到其他类库,所以要使用它,必须得另外下载其他类库,而其他类库又用到其他类库,“子子孙孙无穷尽也”,这也许是比较特殊的情况。因此,手动一个个去下载所需类库十分麻烦。另外一种常见情况是,项目中用到的类库有更新,则必须重新下载新版本,重新加入到项目中,十分麻烦。如果能有什么工具能解决这些恼人的问题,那将“善莫大焉”,而 CocoaPods可以解决此类问题!

CocoaPods应该是iOS最常用最有名的   类库管理工具 了,上述两个烦人的问题,通过cocoaPods,只需要一行命令就可以完全解决,当然前提是必须正确设置它。重要的是,绝大部分有名的开源类库,都支持CocoaPods。所以,作为iOS程序必须掌握CocoaPods的使用。

如何下载和安装CocoaPods?
在安装CocoaPods之前,首先要在本地安装好Ruby环境   --   默认Mac系统己安装有Ruby

假如在本地已经有Ruby环境,那么下载和安装CocoaPods将十分简单,步骤为:

1、打开Terminator(也就是终端)

2、在Terminator(也就是终端)中输入以下命令:

$sudo gem install cocoapods

直到看到下面提示:

3、接下来进行安装,执行:-- 需翻墙连外网

$pod setup

等待安装完毕

使用CocoaPods

1、在终端进入项目所在目录(项目根目录)

2、创建Podfile文件

$ vim Podfile

输入:

platform :ios, '10.0'
use_frameworks!

target '工程名' do
    pod 'SwiftyJSON'
    pod 'Alamofire', '~> 4.0'
end

ps: 可以通过 pod init命令快速创建一个Podfile模板

$pod init

自动生成的模板文件:

3、保存退出, 执行

pod install // or

pod install   //安装
// or
pod update --no-repo-update   //更新库文件

注意:

1.从此以后需要使用Cocoapods生成的 .xcworkspace文件来打开工程,而不是使用以前的.xcodeproj文件

2.每次更改了Podfile文件,都需要重新执行一次pod update命令

补充 :
当执行pod install之后,除了Podfile,还会生成一个名为Podfile.lock的文件,它会锁定当前各依赖库的版本,之后即使多次执行pod install也不会更改版本,只有执行pod update才会改变Podfile.lock.在多人协作的时候,这样可以防止第三方库升级时候造成大家各自的第三方库版本不一致。所以在提交版本的时候不能把它落下,也不要添加到.gitignore中.


Comments are closed.